Обход ограничений безопасности в GnuPG

Дата публикации:
22.03.2006
Всего просмотров:
1099
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GnuPG / gpg 1.2.x
GnuPG / gpg 1.0.x
GnuPG / gpg 1.3.x
GnuPG / gpg 1.4.x
Уязвимые версии: GnuPG версии до 1.4.2.2

Описание:
Уязвимость позволяет удаленному пользователю обойти ограничения безопасности.

Уязвимость существует из-за ошибки при обнаружении неподписанных данных. Удаленный пользователь может внедрить произвольные данные в подписанное сообщение и повлиять на проверку подлинности включенных в сообщение сигнатур и сигнатур, добавленных в зашифрованное сообщение.

URL производителя: www.gnupg.org

Решение: Установите последнюю версию (1.4.2.2) с сайта производителя.

Ссылки: GnuPG does not detect injection of unsigned data

или введите имя

CAPTCHA