Обход ограничений безопасности в GuppY

Дата публикации:
14.03.2006
Всего просмотров:
1541
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GuppY 4.x
Уязвимые версии: GuppY 4.5.11 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю обойти ограничения безопасности.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "pg" сценария "dwnld.php" при записи данных счетчика в ".dtb" файлы. Удаленный пользователь может с помощью символов обхода каталога перезаписать произвольные файлы на системе. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена. Пример:

http://victim/guppy/mobile/dwnld.php?pg=./%2E./stats
http://victim/guppy/dwnld.php?pg=./%2E./test.inc%00

URL производителя: www.freeguppy.org

Решение: Установите последнюю версию (4.5.12) с сайта производителя.

Ссылки: GuppY <= 4.5.11 Remote DoS vulnerability

или введите имя

CAPTCHA