Межсайтовый скриптинг и SQL-инъекция в Gregarius

Дата публикации:
08.03.2006
Всего просмотров:
1458
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Gregarius 0.x
Уязвимые версии: Gregarius 0.52 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "folder" сценария feed.php. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольные SQL команды в базе данных приложения. Удачная эксплуатация уязвимости возможна при выключенной опции "magic_quotes_gpc". Примеры:

search.php?rss_query=aa%')) UNION select null,null,null,null,
null,null,null,null,null,null,null,title,null from item-- &rss_query_match=exact

feed.php?folder=3 and 1=1 UNION select title from item--

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "rss_query" в сценарии search.php и параметре "tag" в сценарии tags.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценарий в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

tags.php?tag=<script>alert(1)</script>
search.php?rss_query=<script>alert(1)</script>&rss_query_match=exact

URL производителя: gregarius.net

Решение: Установите исправление с сайта производителя.

Ссылки: Gregarius 0.5.2 XSS and SQL Injection Vulnerabilities

или введите имя

CAPTCHA