Межсайтовый скриптинг в WordPress

Дата публикации:
06.03.2006
Всего просмотров:
1244
Опасность:
Низкая
Наличие исправления:
Частично
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-0985
CVE-2006-0986
CVE-2006-1796
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие системных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Wordpress 0.x
Wordpress 1.x
WordPress 2.x
Уязвимые версии: WordPress 2.0.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "Name" и "Website" в сценарии wp-comments-post.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Удаленный пользователь может с помощью специально сформированного запроса получить данные об установочной директории на системе.

Пример/Эксплоит: см. источник сообщения.

URL производителя: wordpress.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

Ссылки: [N]eo [S]ecurity [T]eam [NST]? WordPress 2.0.1 Multiple Vulnerabilities

или введите имя

CAPTCHA