Отказ в обслуживании в CrossFire

Дата публикации:
02.03.2006
Дата изменения:
01.11.2008
Всего просмотров:
1879
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CrossFire 1.x
Уязвимые версии: CrossFire 1.8.0 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании приложения.

Уязвимость существует из-за ошибки при обработке опции "oldsocketmode". Злоумышленник может аварийно завершить работу службы путем активации опции "oldsocketmode" и посылкой слишком длинного запроса.

Пример/Эксплоит:
aluigi.altervista.org/poc/crossfirebof.zip

URL производителя: crossfire.real-time.com/index.html

Решение: Установите последнюю версию (1.9.0) с сайта производителя.

или введите имя

CAPTCHA