Межсайтовый скриптинг в Gästebuch

Дата публикации:
27.02.2006
Всего просмотров:
1237
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
php4scripte.de Gästebuch 1.x
Уязвимые версии: Gästebuch 1.3.2 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в поле Homepage. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта во время просмотра сообщения в гостевой книге. Пример:

http://www.site.com/"<script>alert(123)</script>"

URL производителя: www.php4scripte.de/gast.php

Решение: Установите последнюю версию (1.3.3) с сайта производителя.

Источник:

Ссылки: XSS vulnerability in guestbook-php-script

или введите имя

CAPTCHA