PHP-инклюдинг в DocMGR

Дата публикации:
24.02.2006
Всего просмотров:
1237
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
DocMGR 0.x
Уязвимые версии: DocMGR 0.54.2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "includeModule" и "siteModInfo" в сценарии "/modules/center/admin/accounts/process.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Удачная эксплуатация уязвимости возможна при включенной опции "register_globals". Инклюдинг локальных файлов возможен при выключенной опции "magic_quotes_gpc". Инклюдинг удаленных файлов возможен с удаленного FTP сервера и требует наличие PHP 5 на целевой системе.

Пример/Эксплоит: см. источник сообщения.

URL производителя: www.docmgr.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

Ссылки: DocMGR <= 0.54.2 arbitrary remote inclusion

или введите имя

CAPTCHA