Переполнение буфера в GNU Tar

Дата публикации:
23.02.2006
Дата изменения:
09.09.2008
Всего просмотров:
2287
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GNU Tar 1.x
Уязвимые версии: GNU Tar 1.15.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки при обработке расширенных заголовков PAX. Удаленный пользователь может с помощью специально сформированного архива вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: www.gnu.org/software/tar/

Решение: Установите исправленную версию 1.15.90 (alpha) с сайта производителя.

Ссылки: tar 1.15.90 released
http://lists.gnu.org/archive/html/bug-tar/2006-02/msg00051.html

или введите имя

CAPTCHA