Межсайтовый скриптинг и обход ограничений безопасности в SquirrelMail

Дата публикации:
23.02.2006
Дата изменения:
17.10.2006
Всего просмотров:
2020
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-0188
CVE-2006-0195
CVE-2006-0377
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SquirrelMail 1.x
Уязвимые версии: SquirrelMail 1.4.5 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и обойти ограничения безопасности.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "right_main" сценария "webmail.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных комментариях в стилях. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для удачной эксплуатации уязвимости пользователь должен просмотреть злонамеренные данные с помощью браузера Internet Explorer.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "sqimap_mailbox_select mailbox" перед использованием данных в IMAP запросе. Удаленный пользователь может выполнить произвольные IMAP команды на системе.

URL производителя: www.squirrelmail.org

Решение: Установите последнюю версию (1.4.6) с сайта производителя.

Источник:

Ссылки: Possible XSS through right_frame parameter in webmail.php.
Possible XSS in MagicHTML, IE only.
IMAP injection in sqimap_mailbox_select mailbox parameter

или введите имя

CAPTCHA