Множественные уязвимости в PostNuke

Дата публикации:
22.02.2006
Всего просмотров:
1677
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-0800
CVE-2006-0801
CVE-2006-0802
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PostNuke 0.x
Уязвимые версии: PostNuke 0.761 и более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти ограничения безопасности, произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Удаленный пользователь может обойти фильтрацию HTML тегов в функциях "pnVarCleanFromInput()" и "pnAntiCracker()". Пример:

<HTMLTAG? <

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "htmltext" сценария user.php и параметре "language" в модуле NS-Languages. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/user.php?op=edituser&htmltext=[code]
http://[host]/admin.php?module=NS-Languages&op=missing&language=">[code]
http://[host]/admin.php?module=NS-Languages&op=translation&language=[code]

3. Ошибка разграничения доступа позволяет удаленному пользователю, не имеющему административных привилегий получить доступ к некоторым модулям (например, NS-Languages и Banners). Пример:

http://[host]/admin.php?module=NS-Languages
http://[host]/admin.php?module=Banners

4. Уязвимость существует из-за недостаточной обработки входных данных в параметре "language" в модуле NS-Languages. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольные SQL команды в базе данных приложения. Удачная эксплуатация уязвимости возможны при выключенной опции "magic_quotes_gpc". Пример:

http://[host]/admin.php?module=NS-Languages&op=missing&language=[sql]

URL производителя: www.postnuke.com

Решение: Установите последнюю версию (0.762) с сайта производителя.

Источник:

Ссылки: Multiple vulnerabilities in PostNuke <= 0.761

или введите имя

CAPTCHA