PHP-инклюдинг в Admbook

Дата публикации:
22.02.2006
Дата изменения:
17.10.2006
Всего просмотров:
2198
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Admbook 1.x
Уязвимые версии: Admbook 1.2.2 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в HTTP заголовке "X-Forwarded-For" перед записью их в файл "content-data.php". Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Удачная эксплуатация уязвимости требует, чтобы файл "banned-ip-data.php" был некорректно сконфигурирован (значение по умолчанию).

URL производителя: www.devscripts.com/scripts/1394/Admbook/

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

Ссылки: Admbook <= 1.2.2 (X-Forwarded-For) Remote Command Execution Exploit

или введите имя

CAPTCHA