Межсайтовый скриптинг в My Blog

Дата публикации:
20.02.2006
Всего просмотров:
1327
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
My Blog 1.x
Уязвимые версии: My Blog 1.63, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в BBcode тегах [url] и [img]. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

img]javascript:alert(123)[/img]
[url=javascript:alert(123)]Click me[/url]

URL производителя: www.fuzzymonkey.org/cgi-bin/newfuzzy/software.cgi

Решение: Установите последнюю версию (1.65) с сайта производителя.

Источник:

Ссылки: [eVuln] My Blog BBCode XSS Vulnerabilities

или введите имя

CAPTCHA