Межсайтовый скриптинг в V-webmail

Дата публикации:
20.02.2006
Всего просмотров:
2928
Опасность:
Низкая
Наличие исправления:
Частично
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-0792
CVE-2006-0793
CVE-2006-0794
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие системных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
V-webmail 1.x
Уязвимые версии: V-webmail 1.6.2, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "newid" в сценарии preferences.personal.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/preferences.personal.php?newid=[code]

2. Уязвимость существует из-за недостаточной проверки входных данных в параметре "rframe" в сценарии frameset.php. Удаленный пользователь может с помощью специально сформированного запроса загрузить страницу произвольного сайта выполнить код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/frameset.php?vwebmailsession=&rframe=[url]

3. Удаленный пользователь может запросить сценарий "help.php" и получить данные об установочной директории приложения на сервере.

URL производителя: www.v-webmail.org

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA