Межсайтовый скриптинг и SQL-инъекция в MyBB

Дата публикации:
17.02.2006
Дата изменения:
17.10.2006
Всего просмотров:
2703
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MyBB (formerly MyBulletinBoard) 1.x
Уязвимые версии: MyBB 1.0.3 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападении и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "gid" сценария managegroup.php. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольные SQL команды в базе данных приложения. Удачная эксплуатация уязвимости возможна при наличии group leader привилегий.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "gid" в сценарии "managegroup.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценарий в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.mybboard.com

Решение: Установите последнюю версию (1.0.4) с сайта производителя.

Источник:

Ссылки: MyBB1.0.3~managegroup.php~Multiple SqlInjection & XSS

или введите имя

CAPTCHA