Отказ в обслуживании в PAM-MySQL

Дата публикации:
16.02.2006
Дата изменения:
17.10.2006
Всего просмотров:
1226
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-0056
CVE-2005-4713
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PAM-MySQL 0.x
Уязвимые версии: PAM-MySQL 0.6.1 и 0.7pre2 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании.

1. Неизвестная ошибка в логировании SQL запросов может позволить злоумышленнику вызвать отказ в обслуживании системы.

2. Ошибка двойного освобождения обнаружена в модуле аутентификации при обработке указателя, возвращаемого функцией "pam_get_item()". Удаленный пользователь может с помощью специально сформированного пароля вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

URL производителя: pam-mysql.sourceforge.net

Решение: Установите последнюю версию (6.2) с сайта производителя.

или введите имя

CAPTCHA