Межсайтовый скриптинг в CPAINT

Дата публикации:
16.02.2006
Всего просмотров:
1033
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CPAINT 1.x
CPAINT 2.x
Уязвимые версии: CPAINT 2.0.2 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "cpaint_response_type" сценария "type.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/type/type.php?cpaint_response_type=[code]

URL производителя: cpaint.booleansystems.com

Решение: Установите последнюю версию (2.0.3) с сайта производителя.

Источник:

Ссылки: CPAINT security hole found and fixed!

или введите имя

CAPTCHA