PHP-инклюдинг в PHP iCalendar

Дата публикации:
10.02.2006
Всего просмотров:
2543
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP iCalendar 2.x
Уязвимые версии: PHP iCalendar 2.0.1, 2.1 и 2.2

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "file" в сценарии "functions/template.php" и параметре "getdate" в сценарии "search.php". Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера.

URL производителя: phpicalendar.net

Решение: Установите исправление с сайта производителя.

Источник:

Ссылки: [eVuln] PHP iCalendar File Inclusion Vulnerability

или введите имя

CAPTCHA