Обход ограничений безопасности в phpBB

Дата публикации:
08.02.2006
Дата изменения:
24.03.2009
Всего просмотров:
6659
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Брут-форс атака
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpBB 2.x
Уязвимые версии: phpBB 2.0.19, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести брут-форс атаку.

Уязвимость существует из-за того, что функция "gen_rand_string()" генерирует угадываемые случайные номера. Удаленный пользователь может изменить пароль к целевой учетной записи с помощью функционала восстановления пароля путем отправки большого количества запросов для подбора Validation ID (не более 1000000 запросов). Для удачной эксплуатации уязвимости злоумышленнику необходимо знать e-mail целевой учетной записи.

Пример/Эксплоит: см. источник сообщения.

URL производителя: www.phpbb.com

Решение: Установите последнюю версию с сайта производителя.

Источник:

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: Exploiting Pseudo Random Number Generators in PHP

или введите имя

CAPTCHA