PHP-инклюдинг в Loudblog

Дата публикации:
07.02.2006
Дата изменения:
27.10.2008
Всего просмотров:
1572
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Loudblog 0.x
Уязвимые версии: Loudblog 0.4, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "path" в сценарии "loudblog/inc/backend_settings.php". Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный PHP код на целевой системе с привилегиями Web сервера. Удачная эксплуатация уязвимости возможна при включенной опции "register_globals".

Пример/Эксплоит: см. источник сообщения.

URL производителя: loudblog.de

Решение: Установите последнюю версию 0.42 с сайта производителя.

Ссылки: LoudBlog <= 0.4 arbitrary remote inclusion

или введите имя

CAPTCHA