Межсайтовый скриптинг и SQL-инъекция в PHP GEN

Дата публикации:
07.02.2006
Всего просмотров:
1259
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-0497
CVE-2006-0498
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP GEN 1.x
Уязвимые версии: PHP GEN 1.3, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападении и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в некоторых параметрах. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в некоторых параметрах. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценарий в браузере жертвы в контексте безопасности уязвимого сайта.

Подробности уязвимостей не сообщаются.

URL производителя: www.eyce.be/php_gen/

Решение: Установите последнюю версию (1.4) с сайта производителя.

или введите имя

CAPTCHA