Переполнение динамической памяти в libpng

Дата публикации:
01.02.2006
Дата изменения:
28.10.2008
Всего просмотров:
1549
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
libpng 1.x
Уязвимые версии: libpng 1.0.16, 1.0.17, 1.2.6 и 1.2.7

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Переполнение буфера существует в функции "png_set_strip_alpha()" при обработке PNG файлов, содержащих alpha потоки. Удаленный пользователь может с помощью специально сформированного PNG файла выполнить произвольный код на целевой системе.

URL производителя: www.libpng.org

Решение: Установите последнюю версию (1.0.18 или 1.2.8) с сайта производителя.

Ссылки: libpng heap based buffer overflow

или введите имя

CAPTCHA