PHP-инклюдинг в PmWiki

Дата публикации:
31.01.2006
Дата изменения:
17.10.2006
Всего просмотров:
2614
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PmWiki 2.x
Уязвимые версии: PmWiki 2.1 beta 20 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю обойти ограничения безопасности и скомпрометировать уязвимую систему.

Уязвимость существует в дерегистрации уровня "register_globals" при обработке параметров массива "GLOBALS". Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе и произвести XSS нападение. Пример:

http://[victim]/pmwiki.php?GLOBALS&GLOBALS[FarmD]=[file]

Для удачной эксплуатации уязвимости необходимо, чтобы опция "register_globals" была включена.

URL производителя: www.pmwiki.org

Решение: Установите последнюю версию (2.1 beta 21) с сайта производителя.

Источник:

Ссылки: PmWiki Multiple Vulnerabilities

или введите имя

CAPTCHA