Выполнение произвольного кода в CommuniGate Pro Server

Дата публикации:
31.01.2006
Дата изменения:
17.10.2006
Всего просмотров:
3440
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CommuniGate Pro 5.x
Уязвимые версии: CommuniGate Pro Server 5.0.6 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки в компоненте LDAP при обработке отрицательного значения длины в полях Basic Encoding Rules (BER). Удаленный пользователь может с помощью специально сформированного LDAP пакета вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Пример/Эксплоит:
Proof of concept for CommuniGate Pro Server vulnerability

URL производителя: www.stalker.com/content/groupware.htm

Решение: Установите последнюю версию (5.0.7) с сайта производителя.

Источник:

Ссылки: Multiple vulnerabilities in CommuniGate Pro Server

или введите имя

CAPTCHA