Множественные уязвимости в Winamp

Дата публикации:
30.01.2006
Дата изменения:
06.04.2009
Всего просмотров:
3705
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2005-3188
CVE-2006-0476
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Winamp 5.x
Уязвимые версии: Nullsoft Winamp 5.12 и более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольный код на целевой системе.

1. Переполнение буфера обнаружено при обработке имен файлов плейлистах. Удаленный пользователь может с помощью специально сформированного .pls или .m3u файла выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки проверки границ данных при обработке плейлистов с расширением .wma. Удаленный пользователь может с помощью специально сформированного плейлиста вызвать переполнение буфера и выполнить произвольный код на целевой системе. Уязвимость была устранена без уведомления в версии 5.11.

URL производителя: www.winamp.com

Решение: Установите последнюю версию 5.13 с сайта производителя.

Ссылки: Nullsoft Winamp Player <= 5.12 PLS File Handling Remote Buffer Overflow Exploit
http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=377
http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=378

или введите имя

CAPTCHA