Межсайтовый скриптинг и SQL-инъекция в SimpleBlog

Дата публикации:
19.01.2006
Всего просмотров:
1143
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-0239
CVE-2006-0240
CVE-2006-4300
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SimpleBlog 2.x
Уязвимые версии: SimpleBlog 2.1, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападении и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "month". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://[victim]/?view=archives&month=[code]&year=2006

2. Уязвимость существует из-за недостаточной обработки входных данных в различных полях формы при создании комментария. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценарий в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.8pixel.net/?pageID=2

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

Ссылки: [HSC Security Group] Multiple SQL injection/XSS in SimpleBlog 2.1

или введите имя

CAPTCHA