Межсайтовый скриптинг в Faq-O-Matic

Дата публикации:
19.01.2006
Всего просмотров:
1150
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Faq-O-Matic 2.x
Уязвимые версии: Faq-O-Matic 2.711

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "_duration", "file" и "cmd". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[victim]/fom.cgi?cmd=recent&file=1&showLastModified=show&_submit=Show+documents&_duration=[code]
http://[victim]/fom.cgi?file=[code]&showLastModified=show
http://[victim]/fom.cgi?_insert=answer&cmd=[code]&file=1

URL производителя: faqomatic.sourceforge.net

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

Ссылки: Faq-O-Matic Cross-Site Scripting Vulnerabilities

или введите имя

CAPTCHA