Множественные уязвимости в форуме 427BB

Дата публикации:
11.01.2006
Дата изменения:
24.03.2009
Всего просмотров:
1590
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-0153
CVE-2006-0155
CVE-2006-0154
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
427BB 2.x
Уязвимые версии: 427BB 2.2.1 и более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти ограничения безопасности, произвести XSS нападение и выполнить произвольный SQL команды в базе данных приложения.

1. Обход ограничений безопасности возможен из-за недостаточной обработки входных данных в параметрах "username", "authenticated" и "usertype" в файле куки. Удаленный пользователь может войти в систему под любой учетной записью. Пример:

Cookie: username=admin;
Cookie: authenticated=1;
Cookie: usertype=admin;

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "ForumID" сценария "showthread.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://host/bb427/showthread.php?ForumID=999%20union
%20select%20UserName,Passwrod,null,null%20from%20prefPersonal

3. Межсайтовый скриптинг возможен из-за недостаточной обработки входных данных в "url" bbcode теге. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

[url=javascript:alert(123)]clickme[/url]

URL производителя: sourceforge.net/projects/fourtwosevenbb/

Решение: Установите последнюю версию с сайта производителя.

Источник:

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: 427BB Multiple Vulnerabilities

или введите имя

CAPTCHA