Межсайтовый скриптинг в Enhanced Simple PHP Gallery

Дата публикации:
06.01.2006
Дата изменения:
24.03.2009
Всего просмотров:
1822
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Enhanced Simple PHP Gallery 1.x
Уязвимые версии: Enhanced Simple PHP Gallery 1.7

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "dir" сценария "index.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://www.quirm.net/showcategory.php?categoryid=12

Решение: Установите последнюю версию с сайта производителя.

Источник:

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: Enhanced Simple PHP Gallery "dir" Cross-Site Scripting Vulnerability

или введите имя

CAPTCHA