Межсайтовый скриптинг в VMware ESX Server

Дата публикации:
03.01.2006
Дата изменения:
24.09.2007
Всего просмотров:
2666
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2005-4583
CVE-2005-3619
Вектор эксплуатации:
Локальная сеть
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
VMware ESX Server 2.x
Уязвимые версии: VMware ESX Server 2.0.x, 2.1.x и 2.5.x

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в Management Interface. Удаленный пользователь может с помощью специально сформированных FTP команд выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта при просмотре журнала событий FTP сервера.

URL производителя: www.vmware.com

Решение: Установите последнюю версию с сайта производителя.

VMware ESX Server 2.0.1: Apply upgrade patch 6.
http://www.vmware.com/download/esx/esx-201-200512-patch.html

VMware ESX Server 2.1.2: Apply upgrade patch 6.
http://www.vmware.com/download/esx/esx-212-200512-patch.html

VMware ESX Server 2.5.2: Apply upgrade Patch 2.
http://www.vmware.com/download/esx/esx-252-200512-patch.html

Источник:

Ссылки: Security Response to Remote Code Execution Vulnerability in VMware Management Interface

или введите имя

CAPTCHA