Межсайтовый скриптинг в AdesGuestbook

Дата публикации:
31.12.2005
Дата изменения:
24.03.2009
Всего просмотров:
1885
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
AdesGuestbook 2.x
Уязвимые версии: AdesGuestbook 2.0

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "totalRows_rsRead" в сценарии "read.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

/read.php?pageNum_rsRead=1&totalRows_rsRead=[XSS]

URL производителя: www.adesdesign.net/php/products_adesguestbook.php

Решение: Установите последнюю версию с сайта производителя.

Источник:

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: AdesGuestbook XSS vuln.

или введите имя

CAPTCHA