Межсайтовый скриптинг GFHost / GmailSite

Дата публикации:
30.12.2005
Всего просмотров:
2034
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GFHost 0.x
GmailSite 1.x
Уязвимые версии:
GFHost 0.4.2
GmailSite 1.0.4

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "lng" сценария "index.php". Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[VICTIM]/?lng=es"><script>alert(document.cookie)</script>
http://[VICTIM]/index.php?lng=es"><script>alert(document.cookie)</script>

URL производителя: www.gmailsite.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

или введите имя

CAPTCHA