Множественные уязвимости в eggBlog

Дата публикации:
27.12.2005
Дата изменения:
11.01.2009
Всего просмотров:
1847
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2005-4546
CVE-2005-4547
CVE-2006-0349
CVE-2006-0350
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
eggblog 2.x
Уязвимые версии: eggBlog 2.0, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "q" сценария "search.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "id" в сценарии blog.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

3. Уязвимость существует из-за недостаточной обработки входных данных во время публикации сообщения. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта при просмотре специально сформированного сообщения. Пример:

<a href=[url] onmouseover=[code]>[text]</a>

URL производителя: www.eggblog.net/home/

Решение: Установите последнюю версию 3.0b с сайта производителя.

Журнал изменений:

11.01.2009
Изменено описание уязвимости, добавлены уязвимости #2-3, повышен рейтинг опасности, изменена секция «Решение».

Ссылки: eggblog vuln.

или введите имя

CAPTCHA