SQL-инъекция и межсайтовый скриптинг в Honeycomb Archive

Дата публикации:
26.12.2005
Дата изменения:
24.03.2009
Всего просмотров:
1722
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Honeycomb Archive 3.x
Honeycomb Archive Enterprise 3.x
Уязвимые версии: Honeycomb Archive

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "div", "cat", "series" и "cat_parent" в сценарии "CategoryResults.cfm". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды на системе. Пример:

/CategoryResults.cfm?div=7&cat=118&cat_parent=107&series=[SQL]
/CategoryResults.cfm?div=7&cat=118&cat_parent=[SQL]
/CategoryResults.cfm?div=7&cat=[SQL]
/CategoryResults.cfm?div=[SQL]

2. Межсайтовый скриптинг возможен из-за недостаточной обработки входных данных в параметре "keyword" в сценарии "search.cfm". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный HTML код в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.quicksquare.com

Решение: Установите последнюю версию с сайта производителя.

Источник:

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: Honeycomb Archive & Honeycomb Archive Enterprise vuln.

или введите имя

CAPTCHA