Межсайтовый скриптинг в WebCal

Дата публикации:
26.12.2005
Всего просмотров:
2073
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WebCal 3.x
WebCal 2.x
WebCal 1.x
Уязвимые версии: WebCal 1.11 – 3.04

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных параметрах "function", "year" и "date" в сценарии "webcal.cgi" и в различных параметрах календаря. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный HTML код в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: bulldog.tzo.org/webcal/webcal.html

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

Ссылки: WebCal Cross-Site Scripting and Script Insertion Vulnerabilities

или введите имя

CAPTCHA