Межсайтовый скриптинг в PPCal Shopping Cart

Дата публикации:
20.12.2005
Всего просмотров:
2107
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PPCal Shopping Cart 3.x
Уязвимые версии: PPCal Shopping Cart

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует при обработке входных данных в параметрах "user" и "stop" сценария "ppcal.cgi". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный HTML код в браузере жертвы в контексте безопасности уязвимого сайта. Примеры:

/ppcal.cgi?action=shop&user=8001&start=21
& stop=%22%3E%3Cscript%3Ealert('r0t')%3C
/script%3E


/ppcal.cgi?action=shop&user=%22%3E%3Cscri
pt%3Ealert('r0t')%3C/script%3E

URL производителя: www.paypalshoppingcart.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

Ссылки: PPCal Shopping Cart XSS

или введите имя

CAPTCHA