Межсайтовый скриптинг в PDEstore

Дата публикации:
19.12.2005
Дата изменения:
19.12.2005
Всего просмотров:
1073
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PDEstore 1.x
Уязвимые версии: PDEstore 1.8 и более ранние версии

Описание:
Удаленный пользователь может произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "product" и "cart_id" в сценарии "pdestore.cgi". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный HTML код в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

/pdestore.cgi?product=%22%3E%3Cscript
%3Ealert('r0t')%3C/script%3E

/pdestore.cgi?product=jewelry&cart_id
=%22%3E%3Cscript%3Ealert('r0t')%3C/s
cript%3E

URL производителя: www.smart-choices.org/docs/pdestore.html

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

Ссылки: PDEstore XSS vuln.

или введите имя

CAPTCHA