Переполнение буфера в libavcodec в FFmpeg

Дата публикации:
07.12.2005
Всего просмотров:
1495
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2005-4048
CVE-2006-4799
CVE-2006-4800
CVE-2006-0579
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Gentoo Linux 1.x
Уязвимые версии: FFmpeg 0.x

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе или вызвать отказ в обслуживании.

Уязвимость существует из-за ошибки в функции "avcodec_default_get_buffer()" файла "utils.c" в libavcodec. Удаленный пользователь может с помощью специально сформированного 1x1 ".png" файла, содержащего палитру, вызвать переполнение динамической памяти и аварийно завершить работу приложения или выполнить произвольный код на целевой системе с привилегиями текущего пользователя.

URL производителя: ffmpeg.sourceforge.net

Решение: Установите исправление, доступное по CVS.

Источник:

Ссылки: FFmpeg libavcodec Buffer Overflow Vulnerability

или введите имя

CAPTCHA