Межсайтовый скриптинг в GhostScripter Amazon Shop

Дата публикации:
06.12.2005
Дата изменения:
24.03.2009
Всего просмотров:
1863
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GhostScripter Amazon Shop 5.x
Уязвимые версии: GhostScripter Amazon Shop 5.0.0 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует при обработке входных данных в параметре "query" сценария "search.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный HTML код в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

/search.php?query=%3Cscript%3Ealert%28%27r0t%27%29%3
C%2Fscript%3E&mode=all&imageField.x=21&imageField.y=4

URL производителя: www.ghostscripter.com/amazon_shop.php

Решение: Установите последнюю версию с сайта производителя.

Источник:

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: Amazon Shop 5.0.0 XSS vuln.

или введите имя

CAPTCHA