Межсайтовый скриптинг в Java Search Engine

Дата публикации:
05.12.2005
Дата изменения:
17.10.2006
Всего просмотров:
1454
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Java Search Engine 0.x
Уязвимые версии: Java Search Engine (JSE) 0.9.34

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует при обработке входных данных в параметре "q" сценария "search.jsp". Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный HTML сценарий в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

/search.jsp?oe=english&q=%3Cscript%3Ealert
%28%27r0t%27%29%3C%2Fscript%3E&qor=

URL производителя: www.me.lv/jse/

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

Ссылки: JSE XSS vuln.

или введите имя

CAPTCHA