Множественные уязвимости в vtiger CRM

Дата публикации:
29.11.2005
Дата изменения:
02.09.2008
Всего просмотров:
2168
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2005-3821
CVE-2005-3822
CVE-2005-3818
CVE-2005-3819
CVE-2005-3820
CVE-2005-3823
CVE-2005-3824
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Раскрытие системных данных
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
vtiger CRM 4.x
Уязвимые версии: vTiger CRM 4.2 и более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, получить доступ к потенциально важным данным, выполнить произвольные SQL команды и произвольный PHP код на системе.

1. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в модуле RSS агрегатора . Удаленный пользователь может с помощью специально сформированной новостной ленты выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "date" и "record" и в поле username на странице входа. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости в параметре "date" и поле username опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

4. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "action" и "module". Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе и выполнить произвольный код на целевой системе, путем внедрения PHP кода в файл "vtigercrm.log". Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

5. Уязвимость существует из-за недостаточной обработки входных данных в имени пользователя на странице регистрации. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

6. Уязвимость существует из-за недостаточной проверки входных данных в параметре "templatename" в модуле "Users" перед вызовом функции "eval()". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP код на целевой системе с привилегиями Web сервера.

7. Уязвимость существует из-за того, что приложение позволяет загрузку файлов в корневую директорию web сервера. Удаленный пользователь может загрузить и выполнить произвольный PHP код на целевой системе.

URL производителя: www.vtiger.com/index.php?option=com_content&task=view&id=27&Itemid=55

Решение: Установите последнюю версию 4.2.3 с сайта производителя.

Ссылки: Multiple vulnerabilities in vTiger CRM

или введите имя

CAPTCHA