Межсайтовый скриптинг и изменение перенаправлений в VHCS

Дата публикации:
28.11.2005
Дата изменения:
17.10.2006
Всего просмотров:
1396
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2005-3913
CVE-2005-3902
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Внедрение в сессию пользователя
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
VHCS 2.x
Уязвимые версии: VHCS 2.2.0 - 2.4.6.2.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует при обработке входных данных в сценарии "vhcs/gui/errordocs/index.php". Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный HTML код в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

[vhcs_basedir]/dev/inputvalidation%3Cscript
%3Ealert(window.location.hash)%3B%3C/script%3E#XSS

2. Обнаружена ошибка в компоненте управления алиасами доменов при создании и удалении перенаправлений. Удаленный пользователь может подменить записи и перенаправить пользователей на произвольный сайт. Подробности уязвимости не сообщаются.

URL производителя: www.vhcs.net

Решение: Установите исправление с сайта производителя.

Источник:

Ссылки: VHCS 2.x HTTP Error Cross Site Scripting

или введите имя

CAPTCHA