Выполнение произвольных команд в Mambo

Дата публикации:
22.11.2005
Дата изменения:
24.03.2009
Всего просмотров:
6203
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Mambo 4.x
Уязвимые версии: Mambo 4.5.2.3 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные команды на системе.

Уязвимость существует из-за ошибки в уровне эмуляции "register_globals" в сценарии "globals.php". Удаленный пользователь может перезаписать массивы данных, используемые приложением. Злоумышленник может, таким образом, изменить параметр "mosConfig_absolute_path" и выполнить произвольный PHP файл на системе.

Для удачной эксплуатации уязвимости, опция register_globals должна быть отключена в конфигурационном файле PHP.

URL производителя: www.mamboserver.com

Решение: Установите последнюю версию с сайта производителя.

Источник:

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: Mambo "register_globals" Emulation Layer Overwrite Vulnerability

или введите имя

CAPTCHA