PHP инклюдинг и SQL-инъекция в AlstraSoft Template Seller Pro

Дата публикации:
21.11.2005
Всего просмотров:
1567
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2005-3797
CVE-2005-3798
CVE-2006-0222
CVE-2006-4591
CVE-2007-2776
CVE-2007-2777
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
AlstraSoft Template Seller Pro 3.x
Уязвимые версии: AlstraSoft Template Seller Pro 3.25 и более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести SQL-инъекцию и выполнить произвольный PHP сценарий на целевой системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "config[basepath]" сценария "include/paymentplugins/payment_paypal.php" при включенной опции "register_globals". Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный PHP сценарий на целевой системе с привилегиями web сервера.

2. SQL-инъекция возможна из-за недостаточной обработки входных данных в поле username при выключенной опции "magic_quotes_gpc". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.alstrasoft.com

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA