Отказ в обслуживании при обработке ISAKMP IKE сообщений в Openswan

Дата публикации:
16.11.2005
Дата изменения:
16.11.2005
Всего просмотров:
1206
Опасность:
Средняя
Наличие исправления:
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Уязвимые версии: Openswan версии до 2.4.2

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании приложения.

1. Уязвимость существует при обработке IKE пакетов, содержащих некорректную длину 3DES ключа. Удаленный пользователь может с помощью специально сформированного пакета вызвать отказ в обслуживании приложения.

2. Неизвестная ошибка при обработке IKE пакетов может позволить злоумышленнику вызвать отказ в обслуживании приложения.

URL производителя: openswan.org

Решение: Установите последнюю версию (2.4.2) с сайта производителя.

Источник:

Ссылки: Openswan-2 is vulnerable to a Denial of Service attack as reported by NISCC Vulnerability Advisory 273756/NISCC/ISAKMP

или введите имя

CAPTCHA