Переполнение буфера при NTLM аутентификации в wget и curl

Дата публикации:
14.10.2005
Дата изменения:
17.10.2006
Всего просмотров:
2628
Опасность:
Высокая
Наличие исправления:
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Уязвимые версии:
wget 1.10
curl 7.10.6 - 7.14.1
libcurl 7.10.6 - 7.14.1

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной проверки границ входных данных в имени пользователя при NTLM аутентификации. Удаленный пользователь может вызвать переполнение стека и выполнить произвольный код на целевой системе.

Решение: Установите последнюю версию с сайта производителя.

Источник:

Ссылки: Multiple Vendor wget/curl NTLM Username Buffer Overflow Vulnerability

или введите имя

CAPTCHA