Обход ограничений безопасности в Ruby

Дата публикации:
23.09.2005
Всего просмотров:
1349
Опасность:
Низкая
Наличие исправления:
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Уязвимые версии: Ruby 1.6 - 1.6.8, 1.8 - 1.8.2

Описание:
Уязвимость позволяет удаленному пользователю обойти ограничения безопасности.

Уязвимость обнаружена в файле 'eval.c'. Удаленный пользователь может обойти безопасный уровень ограничений и выполнить произвольный сценарий.

URL производителей: www.ruby-lang.org

Решение: Установите исправленную версию (1.8.3) с сайта производителя.
ftp://ftp.ruby-lang.org/pub/ruby/ruby-1.8.3.tar.gz

Ссылки: Ruby vulnerability

или введите имя

CAPTCHA