Несколько уязвимостей в phpPgAds и phpAdsNew

Дата публикации:
21.08.2005
Дата изменения:
28.04.2009
Всего просмотров:
2710
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Openads for PostgreSQL (ранее phpPgAds) 2.x
Уязвимые версии: phpPgAds, phpAdsNew 2.0.5 и более ранние версии

Описание: Уязвимости позволяют удаленному пользователю выполнить произвольный код на целевой системе, включить и выполнить произвольные локальные файлы и внедрить SQL команды.

Уязвимость обнаружена в сторонней XML-RPC библиотеке. Удаленный пользователь может выполнить произвольный код на целевой системе.

Не фильтруются некоторые GET переменные. Удаленный пользователь может заставить систему включить локальные файлы.

Программа не проверяет данные в 'clientid' параметре. Удаленный пользователь может представить специально обработанное значение чтобы выполнить произвольные SQL команды на основной базе данных.

URL производителя: http://phpadsnew.com/

Решение:Установите обновленную версию уязвимых программ.

или введите имя

CAPTCHA